1

Exchange 2016 CU20 PrepareAD Required

This is a quick heads up for those who may be deploying Exchange 2016 in the near future.  If you are currently on Exchange 2016 CU19 there are no AD schema changes required, but there are AD changes.  The former is performed by /PrepareSchema, and the latter by /PrepareAD.

You can take a look at the history of Exchange 2016 schema changes in Active Directory schema changes in Exchange Server and this page has the Exchange Active Directory versions.

The tables in the following sections contain the Exchange objects in Active Directory that are updated each time you install a new version of Exchange (a new installation or a CU). You can compare the object versions you see with the values in the tables to verify that Exchange successfully updated Active Directory during the installation.

Exchange 2016 Active Directory Versions

The article lists a brief description for each of the columns:

  • rangeUpper is located in the Schema naming context in the properties of the ms-Exch-Schema-Version-Pt container.
  • objectVersion (Default) is the objectVersion attribute located in the Default naming context in the properties of the Microsoft Exchange System Objects container.
  • objectVersion (Configuration) is the objectVersion attribute located in the Configuration naming context in Services > Microsoft Exchange in the properties of the <Your Exchange Organization Name> container.

Lab Example

In the below Tailspintoys.ca lab, initially Exchange 2016 CU19 with the latest security updates was installed.

Using the DSQuery commands from this previous post, the initial configuration was:

Checking Initial Exchange Version Information In AD - Exchange 2016 CU19

Then we execute Exchange 2016 CU20 setup.

setup.exe /IAcceptExchangeServerLicenseTerms /PrepareAD

Running Exchange 2016 CU20 PreparedAD

Now that the /PrepareAD task has completed, we can go back and review the attributes in AD.

Note that the schema value remains the same (rangeUpper), but the others have incremented to match the documentation.

Reviewing AD Values After Exchange 2016 CU20 /PrepareAD Was Executed

This illustrates that /PrepareAD is required for Exchange 2016 so please plan accordingly.

NOTE: Ensure that any required security updates are also installed.

Cheers,

Rhoderick

Rhoderick Milne [MSFT]

One Comment

Leave a Reply

Your email address will not be published. Required fields are marked *